Links in Media Items not loading in Web App

Incident Report for Subsplash

Resolved

This incident has been resolved!
Posted Oct 09, 2025 - 09:18 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 09, 2025 - 08:00 PDT

Investigating

We are currently investigating an issue where links in media items are not loading within the Web App.
Posted Oct 09, 2025 - 07:49 PDT
This incident affected: Web tools.