Live Streaming Disruption

Incident Report for Subsplash

Postmortem

Summary:

A service disruption on March 8th impacted Subsplash Live performance and access to the Live section of the dashboard. During a period of high traffic, a rate limiting setting on our recently updated web gateway incorrectly flagged internal system traffic as an overload. This prevented some users from accessing their Subsplash Live accounts and caused a drop in livestream connection success rates.

Timeline, Resolution & Recovery:

  • Incident start: 6:00 AM PST
  • Fix Applied: Our engineering team identified the bottleneck and disabled the restrictive setting at 7:30 AM PST, restoring full service by 7:38 AM PST.
  • Video Backfill: All "Live-to-On-Demand" videos that were delayed during the outage have been successfully processed and are now visible in your library.

Next Steps: 

To ensure long-term stability and as part of our ongoing infrastructure enhancements, we have refined our internal routing protocols. This change allows essential system traffic to bypass traffic filtering while maintaining the integrity of the security measures protecting Subsplash Live.

Posted Mar 13, 2026 - 11:41 PDT

Resolved

This incident has been resolved.
Posted Mar 08, 2026 - 08:30 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2026 - 07:59 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 08, 2026 - 07:40 PDT

Investigating

We’re investigating the current livestream disruption, and our team is working to resolve the situation as quickly as possible.
Posted Mar 08, 2026 - 06:53 PDT
This incident affected: Subsplash Live.