"Something went wrong" error messages across multiple Subsplash features

Incident Report for Subsplash

Resolved

This incident has been resolved.
Posted Mar 06, 2025 - 18:42 PST

Investigating

We are currently investigating an issue causing pages across multiple Subsplash features to display a "Something went wrong" error message. In many cases, refreshing the page will cause it to load correctly.
Posted Mar 06, 2025 - 18:23 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2025 - 18:20 PST

Investigating

We are currently investigating an issue causing pages across multiple Subsplash features to display a "Something went wrong" error message. In many cases, refreshing the page will cause it to load correctly
Posted Mar 06, 2025 - 18:09 PST
This incident affected: Giving and Web tools.