Guest donations are unavailable
Incident Report for Subsplash
Resolved
This incident has been resolved. Guest giving is restored.
Posted Feb 14, 2023 - 10:56 PST
Identified
Our team identified an issue causing guest donations to be unavailable. A fix is being deployed shortly.
Posted Feb 14, 2023 - 10:55 PST
This incident affected: Giving.