SnapPages SSL Issues
Incident Report for Subsplash
Postmortem

Recent SnapPages SSL issues were caused by a change made in our certificate distribution process that resulted in security warnings for websites that did not meet SnapPage’s recommended DNS settings. We are actively working on expanding the flexibility of our distribution process to avoid such issues in the future.

If you are still experiencing security warnings on your website, please refer to this article for guidance on how to resolve these:
https://help.snappages.site/s/article/ssl-issues

If you are in need of further assistance, please don’t hesitate to reach out to our team at https://help.snappages.site!

Posted Jan 27, 2022 - 08:25 PST

Resolved
This incident has been resolved.
Posted Jan 22, 2022 - 15:06 PST
Identified
We have identified an issue that is causing some websites to encounter site security warnings upon loading. Learn more or contact support by visiting help.snappages.site!
Posted Jan 21, 2022 - 12:21 PST
This incident affected: SnapPages.