Giving block service disruption

Incident Report for Subsplash

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 10:36 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2026 - 10:29 PDT

Investigating

Giving website blocks are currently failing to load.
Posted Mar 26, 2026 - 10:20 PDT
This incident affected: Giving (Subsplash Giving).