Email Distribution Disruption
Incident Report for Subsplash
Resolved
Our team has increased our email capacity going forward and reenabled gift confirmation emails. All systems are now fully operational.
Posted Mar 23, 2020 - 08:09 PDT
Monitoring
Our team is working to have our email capacity increased to account for increased volume going forward. In the meantime, we have temporarily disabled gift confirmation emails to ensure that all new donors and app users can sign up without any problem. We will continue to monitor and adjust accordingly.
Posted Mar 22, 2020 - 17:27 PDT
Identified
Our team has identified a disruption in our email delivery service. Delays in end-user verification and confirmation emails are to be expected. We are working on increasing our system capacity and anticipate all emails to deliver soon.
Posted Mar 22, 2020 - 14:19 PDT
This incident affected: Mobile apps and Giving.