Increased error rates and response times
Incident Report for Subsplash
Resolved
This issue has been identified and resolved.
Posted May 11, 2020 - 10:22 PDT
Investigating
Our team is currently investigating a series of increased error rates and slow response times associated with Subsplash Giving.
Posted May 11, 2020 - 09:56 PDT
This incident affected: Giving.