Some users might encounter issues loading the Subsplash Giving Dashboard
Incident Report for Subsplash
Resolved
We have refreshed login sessions to expedite a resolution for all dashboard users and believe this to be fully resolved. If you continue to encounter login issues, please contact support@subsplash.com. Thank you!
Posted Jan 06, 2021 - 10:40 PST
Monitoring
We believe we have resolved this issue but will continue to monitor to ensure a full resolution. If you are continuing to encounter issues, please contact support@subsplash.com.
Posted Jan 05, 2021 - 20:21 PST
Identified
We are working to resolve an issue that might cause some users to encounter a blank page when loading the Subsplash Giving Dashboard. This issue only affects admins and not donors.
Posted Jan 05, 2021 - 14:07 PST
This incident affected: Giving.