Service degradation
Incident Report for Subsplash
Resolved
This incident is now resolved.
Posted Sep 07, 2021 - 14:15 PDT
Monitoring
A fix has been implemented and we are seeing improved performance. We will continue monitoring until we are confident that all systems are operational.
Posted Sep 07, 2021 - 13:46 PDT
Update
We are continuing to investigate this issue. Images and analytics are experiencing a service disruption.
Posted Sep 07, 2021 - 13:39 PDT
Investigating
We are currently investigating an issue affecting images and 502 errors.
Posted Sep 07, 2021 - 13:13 PDT
This incident affected: Mobile apps, Giving, and Web tools.