Multiple Subsplash services displaying error messages

Incident Report for Subsplash

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 10:05 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2026 - 10:00 PST

Investigating

We are currently investigating an issue causing multiple services to display error messages including giving, events images, and images in the mobile app.
Posted Mar 02, 2026 - 09:34 PST
This incident affected: Apps (Mobile apps), Giving (Subsplash Giving, Giving Dashboard), and Events.