Church Management Outage
Incident Report for Subsplash
Resolved
This incident has been resolved.
Posted Feb 23, 2023 - 16:05 PST
Monitoring
Church management dashboards are loading properly, our team is monitoring the situation to ensure the issue is resolved.
Posted Feb 23, 2023 - 15:56 PST
Investigating
We are currently investigating this issue.
Posted Feb 23, 2023 - 15:44 PST
This incident affected: Dashboards.