Giving dashboard service disruption
Incident Report for Subsplash
Resolved
This incident has been resolved.
Posted Jan 28, 2022 - 14:38 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 28, 2022 - 13:59 PST
Investigating
We are experiencing intermittent errors within Subsplash Giving Dashboard.
Posted Jan 28, 2022 - 13:47 PST
This incident affected: Giving and Dashboards.