SnapPages Dashboard Loading Issues
Incident Report for Subsplash
Resolved
This incident has been resolved.
Posted Nov 17, 2021 - 12:39 PST
Update
We are continuing to investigate this issue.
Posted Nov 17, 2021 - 11:45 PST
Investigating
We are investigating an issue that is causing the SnapPages dashboard (https://app.snappages.site) to fail when loading. All SnapPages websites are still operational.
Posted Nov 17, 2021 - 11:15 PST
This incident affected: SnapPages.