Church Management mailouts not sending

Incident Report for Subsplash

Resolved

This issue is now resolved
Posted Nov 06, 2023 - 12:56 PST

Monitoring

Mailouts are now delivering. We are monitoring to ensure this issue is resolved.
Posted Nov 06, 2023 - 12:48 PST

Investigating

We are currently investigating an issue related to mailouts not being sent.
Posted Nov 06, 2023 - 12:25 PST
This incident affected: Church Management.