Giving Dashboard Loading Issues
Incident Report for Subsplash
Resolved
This incident has been resolved.
Posted Sep 20, 2021 - 09:17 PDT
Investigating
We are currently investigating an issue resulting in Giving Dashboard loading issues and errors. Donors should not be impacted.
Posted Sep 20, 2021 - 08:08 PDT
This incident affected: Giving.