Subsplash Giving returning error message for some donors
Incident Report for Subsplash
Resolved
This incident has been resolved.
Posted Mar 11, 2020 - 08:54 PDT
Monitoring
A fix has been implemented and we are seeing the issue resolved for all donors. We will continue to monitor to ensure that all systems stay completely functional.
Posted Mar 11, 2020 - 08:26 PDT
Identified
The issue was identified and we are rolling back changes that should provide a fix very soon for affected donors.
Posted Mar 11, 2020 - 08:11 PDT
Investigating
We are currently investigating an issue where some Subsplash Giving users receiving error messages and are unable to complete a donation.
Posted Mar 11, 2020 - 07:45 PDT
This incident affected: Giving.