We are encountering issues with Subsplash Giving returning error codes and slow media load times
Incident Report for Subsplash
Postmortem

In response to COVID-19 and the increased traffic on our services on March 15th, Subsplash has taken significant additional steps to prepare for the increased utilization of our platform and services.

It’s more important than ever for churches and ministries to have a delightful and reliable mobile platform to engage their audiences on Sunday and beyond. To prepare for increased traffic and demand, we have provisioned additional database and application capacity for each element of our platform. We also increased safeguards so that donors can give quickly regardless of an increase in traffic on Subsplash Giving. In order to deliver increased platform reliability, each improvement we make will remain active for the foreseeable future.

In the unlikely event that an issue arises, we have improved our monitoring and alerting systems on top of increasing our weekend support. Our Platform Specialist team is ready and available over the weekend to respond to your requests! You can reach them through this link and subscribe to our Status Page to receive updates straight to your phone.

Thank you for partnering with us! Subsplash is here to serve you and fuel the mission you’ve been called to; especially during this time of social distancing and the resulting need for churches to engage digitally!

God Bless,

Subsplash

Posted Mar 17, 2020 - 16:33 PDT

Resolved
Giving, media and app platforms are working as expected and we appreciate your patience.
Posted Mar 15, 2020 - 11:23 PDT
Update
We are continuing to monitor the performance of the mobile app and Subsplash Giving. We invite you to submit a ticket to support@subsplash.com if you see any irregularities.
Posted Mar 15, 2020 - 09:19 PDT
Monitoring
A fix has been implemented and we are seeing Subsplash Giving working as expected. We will continue to closely monitor this situation.
Posted Mar 15, 2020 - 08:42 PDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 15, 2020 - 08:16 PDT
Update
We are continuing to work on Subsplash Giving. Some users can expect normal functionality while others will experience longer loading times or error messages.
Posted Mar 15, 2020 - 08:15 PDT
Update
We are still working on a solution to bring all Subsplash Giving up to 100% functionality.
Posted Mar 15, 2020 - 07:51 PDT
Identified
We have issued a fix for media and are monitoring the results. You should see an improved experience around the app and media. Subsplash Giving is still experiencing errors and we will continue to work to implement a solution.
Posted Mar 15, 2020 - 07:21 PDT
Update
We are continuing to investigate this issue.
Posted Mar 15, 2020 - 07:20 PDT
Investigating
We are currently investigating this issue.
Posted Mar 15, 2020 - 06:52 PDT
This incident affected: Mobile apps, Giving, TV apps, and Web tools.